Symptom:

When running some apps such as the XBox Companion, you get a message "To get the most from this app, switch from your local account to a Microsoft Account on the Users page in PC settings". However, you ARE using your connected account and going to the Users control panel, you only see the option to switch to a local account.

Cause:

This issue will surface if

* You upgraded from Windows 7 and
* In Windows 7, you had linked an online ID with your Windows 7 account. This would have been done in the Windows 7 User Accounts control panel by clicking 'Link Online IDs'.

Workaround:

WARNING:

This article describes how to make changes to the Windows Registry. Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 8 Consumer Preview. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

* Launch regedit from the search charm. (Hover over the lower right corner of the screen to show * Navigate to HKEY_USERS\S-1-5-18\Software\Microsoft\IdentityCRL\StoredIdentities and find the email address that failed to connect.
* For each S-* under the email address look at the keywords node.
* If the keywords node only contains the text 'Associated', then double click on keyword to edit it.
* Append ;Connected such that the entry now appears as 'Associated;Connected' (without the quotes).
* Switch to your local account, then switch back to your Microsoft Account.
* Try to launch your desired application. You should be signed in with the connected account.

Original link: You’re informed to switch to a Microsoft Account when Signing In to Companion apps