Results 1 to 4 of 4

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Posts
    8

    Default No Sound Drivers... Help Please

    I downloaded and installed Windows 8, 32bit, and everything seemed to go very smooth. The only problem is that I have no sound, and it is showing there are no drivers installed for the sound device. I'm running a Sound Blaster X-Fi Fatal1ty sound card. I've gone to the Creative Labs website, tried to download the drivers, but for some reason Windows 8 won't initiate the download. So I used another PC running Windows XP, downloaded the drivers for both XP and Windows 7 (since they don't have drivers for Win8) and burned them to a CD. Then I took that CD, put it in the Windows 8 PC, went to the files (.exe files) and tried to install them. It initiated the extraction, but then while it is in the process of extracting the files it throws up an error and stops (it does this on both the XP and the Windows 7 version). Does anyone have any suggestions? I could go into my BIOS and enable the onboard sound, but what fun is that when you have a Sound Blaster card and surround sound speakers? Can anyone help me?

  2. #2
    Junior Member
    Join Date
    Nov 2011
    Posts
    8

    Default Re: No Sound Drivers... Help Please

    OK, I went in and backed off the security settings in Internet Explorer and got the drivers to download and install, and it was working. Then when I installed all of the software and applications for the Sound Blaster X-Fi Fatal1ty the sound stopped working. I've checked everything I know to check, it's not muted, and everything shows to be working correctly but I don't hear anything. The only other change was a Windows Update. Any suggestions?

  3. Windows 8 Forums Ads
    Join Date
    Mar 2012
    Posts
    1,222

  4. #3
    Junior Member
    Join Date
    Nov 2011
    Posts
    8

    Default Re: No Sound Drivers... Help Please

    I re-installed the drivers it is working again.

  5. #4
    Rob
    Rob is offline
    Junior Member
    Join Date
    Feb 2012
    Posts
    18

    Default Re: No Sound Drivers... Help Please

    as i know that, U should first make sure the Windows Audio Service is enabled and started in Control panel, Administrative Tools, Services.

Thread: No Sound Drivers... Help Please - Windows 8

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Featured Pages:    Windows 8 | Windows 8 Forum | Windows 8 Install | Windows 8 Error | Windows 8 Download | Windows 8 System Requirements | Windows 8 Themes | Windows 8 Key | Windows 8 Drivers| Windows 8 Security | Windows 8 Hardware | Windows 8 Networking | Windows 8 Performance | Windows 8 Sound | Windows 8 Software | Windows 8 Tutorials | Windows 8 Virtualization Virtual Desktop Windows 8 | Windows 8 Registry | Windows 8 Backup | Windows 8 Recovery | Windows 8 Restore | Windows 8 Firewall | Windows 8 Aero Theme | Windows 8 Blue Screen | Windows 8 Activation| SEO by WebProfits