This is for work and google isn't helping. Currently we have a Mac Mini with a 10TB Thunderbolt Raid share for our network "server". We have 5 Mac computers running Mavericks, 2 Running windows 7 and 2 running windows 8.1. I'm having trouble getting the Windows 8.1 machines to access the share drive on the network. The windows 7 computers access it with ZERO problems.

The weird thing is, it's inconsistent. I can see the shared computer and shared folder but it won't load.. 99% of the time. I had it accidentally load when I was saving an excel spreadsheet and it started loading some of the folders in the shared drive... then stopped and started doing the "I can't do this so I'll sit here and be greyed out." thing again. I've tried Mapping the network drive and it works, I can log in and it even shows the Used/Free storage space info after a reboot but when you try to open it... nope. Greyed out. And it locks up the machine.

I have none of these issues with the Windows 7 machines.

I've tried disabling SMB2. I'm not sure what else to do. I have very little experience with Windows 8. Any suggestions would be greatly appreciated.

Thank you,
Jeremy