I am trying to dual boot Windows 8 Home Premium and Ubuntu 10.04 on my laptop (Toshiba Portege M400). I had Ubuntu 10.04 installed previously but I decided to wipe my hard drive before installing Windows 8. I used GParted to delete all my partition and setup two new ones. I formated the first partition as NFTS for Windows 8. After that, I proceeded to installing Windows 8. The first time I tried it, I was successful although I did need to reformat that NFTS partition I had made because it said that the partition table type (GUID) was not compatible. Windows 8 installed fine after that. However, when I try to install Ubuntu, it sees the whole disk as blank. I tried resolving this issue with GParted but that too saw the drive as if it were blank even though Windows 8 was installed. After that, I booted up the GParted Live CD once again and changed the partition table to MS-DOS. My Windows 8 boots up and goes through all the tasks before the first boot up. When it restarts for the first time, it fails to boot; it simply stays on the glowing Windows logo. I've tried formatting the entire disk through the Windows 8 disk and partitioning from there several times and I still get the same results. I've checked my BIOS and put it in it's default settings but still nothing.