PDA

View Full Version : Set Google Chrome as default browser



jamilhaddadin
03-29-2012, 09:53 PM
I want to Set Google chrome as default browser but I could not see it listed in the default programs:
when i go to Default programs || set Your Default program

297

Medico
03-30-2012, 01:50 AM
Read through this thread. (http://www.forumswindows8.com/browsers-mail/why-i-cant-change-default-browser-5424.htm) A word of advise for all members. Your question may have been answered already. Check out some of the already posted threads. You may find some advice that will help with other problems at the same time.

jamilhaddadin
03-30-2012, 06:50 AM
Thanks for ur reply and advice, but i already checked that thread before i posted, as u can see from the picture that i attached, chrome is not listed although it is installed on my machine

Medico
03-30-2012, 03:30 PM
I believe you have to change the File Association rather than Set the default program.

320

TechnoMage
03-30-2012, 03:44 PM
Hi and Welcome!
(Sorry Ted, right church, wrong pew. Associations yes, but those are the wrong ones.)

Well as you already stated, Chrome or whatever you want to use has to be installed. Obviously setting it to be your default Browser didn't have the desired effect. Eh?

I had the same problem with Firefox, , , I told it to become the Default Browser, but every time I clicked on a Link to the internet (URL) it would come up in I.E.10. Grrrrrrr!

OK, the next step was to type "Associations" at the metro page. It will show up in the search Window.
Then click "Settings"
Then click on the top choice box on the left column, that says "Make a file type always open in a specific program"

That will take you to the file associations listing. Scroll down, and down and down some more, till you get to the "Protocols" section. Go on down to FTP, HTTP and HTTPS and set each one to open with your browser.
322

This worked basically the same as in XP , but with just a few Minor differences.

Good Luck,
TechnoMage :cool:

PS: While I was in there, I set all the picture types to "Photo Filtre" , my favorite photo manager.
* this screen capture was done with the "Prt Scrn" key to grab the screen and Photo Filtre to crop and resize the image.

Medico
03-30-2012, 04:50 PM
I do not get this Doc, I get what you see in my screen shot above. I have the latest version of Google Chrome v18 installed but do not see it listed in the Default Programs section and do not see the FTP, HTTP or HTTPS. Wait, Oh I see they are way down to the bottom under protocols, gotcha. You don't have to go to Metro at all though, just open Control Panel (I have a shortcut pinned to QL toolbar) Default Programs, File Associations, and scroll to bottom. I see now, the light bulb just came on in my brain cell.

Thanks for your help TechnoMage (Doc)

jamilhaddadin
03-30-2012, 11:36 PM
Ted: I already changed the mentioned files association but it did not work "TechnoMag was right"
TechnoMag: I could not succeed to change the mentioned protocols as I dont see Chrome listed as one of the options, and there is no browse button, check this please:
326

Thank you all for the great support!

Medico
03-31-2012, 05:04 AM
Mine does not show Google Chrome either. I wonder if Chrome does not load itself into the Default Programs list at this point in the beta program. I do not see any other reason for this. I have installed the latest version of Chrome, version 18 and it does not show up. I have no other suggestions at this time, sorry.

TechnoMage
03-31-2012, 05:50 AM
I'm not on W8 right now and probably won't be till late in the day.
But when the program I want to use is not in the default program list I do go searching for the ProgramName.exe file and select it.

Photo Filtre is a good example. It never inserts itself into the conversation. A bit of a wall flower I guess. I always have to go find the .exe and specify that to be used as the default.

I'm not sure now, if Firefox was in the default program list or not.
Sorry about your bad luck!

TM :cool:

PS: this new look is throwing me for a loop!

Medico
03-31-2012, 06:06 AM
It does take a little getting used to. I found full screen works best so top to bottom shows up completely. That way my scroll button just scrolls left to right. The colors are a little intense and I had to change signature colors. Still have to find a couple of things. People are putting comments in General Discussions.

I will check the Chrome thing when I get a change. Ok when I choose Change program, I do not get a Browse option, just IE or Search MS Store for an app. Yes I can open Win Explorer and find the Chrome exe but how would I choose it? My brain cell is not working this morning.

This is really strange. I cannot find where Google Chrome is installed. It is not in Program Files, or Program Files (x86) as far as I can tell. The only .exe I can find is a shortcut to Google Chrome in the Start Menu, Programs location. Perhaps this is why Chrome is not is not showing up. I have no idea what is going on here.

TechnoMage
03-31-2012, 06:45 AM
I already know, that this won't go over well, but here goes......

I've been using Firefox since the first Beta release.
I was right there on day one of the Full Release and one of the 1 million + that downloaded it.
Chrome wasn't even thought of yet. But when it came out, I asked my Software Guru and Web Master about it. He had tried it and immediately deleted it. His comment to me was something like "it's a real piece of dung". So I have just ignored it, as something I really don't want to mess with.
I like FF and I have it tweaked and tuned for TOP efficiency and it does everything I expect a browser to do. I even have my pet hamster on my home page. Now who could ask for anything more than that? :rolleyes:

TechnoMage :cool:

Medico
03-31-2012, 06:52 AM
I use IE 10 as my default anyway. I was just trying to help the OP. I guess it is not able to be done with this beta release. Perhaps it will not be able to be done with Chrome. Who knows. Have a great weekend.