PDA

View Full Version : Windows not installing after Ubuntu



kikloo
01-10-2014, 02:30 AM
Hi,

I installed Ubuntu 12.04 on my laptop (Acer Aspire 5738Z). It has a simple SATA HDD. Ubuntu installed fine and I did not like it. So I decided to remove it completely and install Windows 8 (I have genuine). I made a bootable ISO USB of Windows 8 and booted from it. The setup started and asked me to select whether Upgrade or do a Custom setup. I selected Custom and deleted all the partitions etc on the drive and tried to install Windows on it but its giving me the following error:

---
We could'nt create a new partition or locate an existing one. For more information view the setup log files.
---

I searched alot on google about this and mostly people are getting this issue who have RAID drives. My simple old laptop has no RAID setup / drive in anyway. I am booting through a USB pendrive and trying to install windows 8 and it used to work everytime earlier I did it. Only after this Ubuntu thing its giving me this problem.

Some suggested that I should do DISKPART etc. and I did the following commands in DISKPART but after doing all its still giving me that error:

---
LIST DISK
SELECT DISK 0
CLEAN ALL
CREATE PARTITION PRIMARY
SELECT PARTITION 1
ACTIVE
FORMAT fs=NTFS
ASSIGN
EXIT
EXIT
---

Then I restarted my laptop but to no avail. The same error keep on popping up.

After this I also tried to install ACHI drivers (As suggested to some people who had RAID). I downloaded the ACHI drivers of Windows Vista from Acer's website and tried to do that also but after installing the drivers it would not show up the disk at all.

So in a nutshell, I have a unusable system with me and I am not able to install Windows 8 on it. What do I do ?? Please help solve this issue. I am been trying to get this work for the last 12 hours or so. Good thing that I have my netbook with me through which I am able to post this message and download drivers etc.

Any help in this regard will be highly appreciated. I curse myself why oh why I installed Ubuntu on my full HDD.

Thanks.

badrobot
01-10-2014, 03:19 AM
Did you reformat/wipe out your hard drive? Windows will not be able to see any hard drive partition in linux format.

bassfisher6522
01-10-2014, 09:30 AM
Did you reformat/wipe out your hard drive? Windows will not be able to see any hard drive partition in linux format.

Yep...I learned that the hard way....the easiest way for me to fix it was use the linux dirtro live cd I had use there's terminal (what linux calls the CMD prompt) and run that code to fix the MBR. There is also a windows code to do the same thing....I'll have to find both and post it.

bassfisher6522
01-10-2014, 09:38 AM
I found these.....

https://help.ubuntu.com/community/Boot-Repair

https://help.ubuntu.com/community/RestoreUbuntu/XP/Vista/7Bootloader

Boot-Repair – Simple tool to repair frequent boot problems (http://www.ubuntugeek.com/boot-repair-simple-tool-to-repair-frequent-boot-problems.html)

and for windows....

How To Fix Windows 8 MBR (Master Boot Record) | Redmond Pie (http://www.redmondpie.com/how-to-fix-windows-8-mbr-master-boot-record/)

How To Fix Windows 8 MBR (Master Boot Record) (http://www.jailbreakeye.com/windows/fix-windows-8-mbr)

How to fix Windows 8 mbr? - Microsoft Community (http://answers.microsoft.com/en-us/windows/forum/windows_8-system/how-to-fix-windows-8-mbr/3d5439e9-521d-445c-ad52-a1d4b7f17237)

TechnoMage
01-10-2014, 10:21 AM
To a casual observer, it would appear that Ubuntu has made the hard drive Unreadable to Windows.

My fix would be to boot up with my DOS Utilities disk and run FDISK to remove any NON-DOS partitions and establish a new DOS compatible partition. Then to clean and certify the hard drive, I'd run the DOS Format command to format the entire drive.

Then any Windows installer should see the drive just fine, and load to it.

I only mention this because I've had to do it in the past. Works for me.

TM :cool: